Tuesday, 1 September 2009

Joomla! Installing XAMPP on Vista

Currently I am working on installing Joomla! content management system and as a first step it requires to install XAMPP package. After some time of tweaking I finally managed to install and run XAMPP package on Vista. XAMPP installation completed fine and basic configuration steps made no problems. All services except Apache started.

image 

Turned out that service was unable to start, because Apache process had no access to “C:\Program Files\xampp” directory. I decided to give SYSTEM account access to it and run Apache, MySql and FileZilla as windows services. To give access to SYSTEM account open properties of the directory and Security Tab.

image

Check that it has full access rights assigned. If not, use Edit button to assign access rights.

After trying to start Apache service again it still was failing to start. Apache log in C:\Program Files\xampp\apache\logs\error.log showed the following error.

“(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions.  : make_sock: could not bind to address [::]:80”

This error happens when some process already uses port 80. My solution was to change “C:\Program Files\xampp\apache\conf\httpd.conf” file and set port to something else like 8080 or any other number. Edit lines “Listen 80” and “ServerName localhost:80” to be  “Listen 8080” and “ServerName localhost:8080”. Start Apache service. Success!

The next step will be to install Joomla! I will publish another post if there will be problems that required solution during install.

2 comments:

  1. Thank you so much for this, helped me too :)

    ReplyDelete
  2. Thank you so much. Had been searching on this for an hour.

    ReplyDelete